5.0 0.5 4 21

Как сделать "if" в Excel?

Samiko
Samiko
23 сентября 2014
131
Оцените:
Как сделать "if" в Excel?

Смотрите видео

Как сделать "if" в Excel?

Прежде чем перейти к рассмотрению синтаксиса функции "if", определим её  назначение. С уроков английского языка известно, что "if "означает "если", а с уроков информатики "if"(ЕСЛИ) - логическая функция условия: ЕСЛИ выполнено условие1, то ИСТИНА, иначе - ЛОЖЬ. Под условием1 подразумевается некоторое логическое выражение (например, сравнение), ИСТИНА - означает, что условие верно. В качестве результата условия может выступать некоторое математическое выражение.

Для понимания рассмотрим пример цен в кинотеатре. Известно, что большинство сеансов в утренние часы (допустим, до 12 часов) стоят дешевле, чем в дневные (до 22 часов), а те, в свою очередь, дешевле вечерних (до 24 часов). Поскольку у нас 3 возможных условия (до 12, до 20 и до 24), то имеем разветвляющийся алгоритм (вложенный цикл if):

  • ЕСЛИ до 12, то 100 руб., ИНАЧЕ
    • ЕСЛИ до 20, то 200 руб.
      • ИНАЧЕ 250 руб.

Использование данной функции пригодится, в первую очередь, математикам, бухгалтерам и финансистам (для начисления заработной платы, расчета кредитов и т.д.). Наиболее просто её реализовать в MS Office Excel, так как "эксель" является наиболее распространенной табличной программой в операционной системе Windows, а синтаксис одинаковый для всех версий (от 97 до 2012).

Как сделать "if" в Excel?

Чтобы использовать функцию, нужно в свободном поле таблицы щелкнуть левой клавишей мыши (ЛКМ), поставить знак "=" и написать "ЕСЛИ". "Эксель" выдаст всплывающую подсказу в виде:

  • ЕСЛИ(лог_выражение;[значение_если_истина];[значение_если_ложь])

Чтобы выбрать данное выражение, нужно щелкнуть по нему 2 раза ЛКМ.

Поля, описанные в квадратных скобках [], являются необязательными.

Рассмотрим на примере:

Пусть у нас имеется склад магазина бытовой техники, и среди товаров необходимо найти телевизоры Российской сборки стоимостью до 15 000 рублей.

Таблица имеет 4 столбца: столбец A-наименование товара, B - страна-производитель, C - цена за товар, D - отметки о нужном товаре.

Для того чтобы выполнились 3 наших условия (Телевизор и Россия и До 15 000 руб ), нужно в свободном поле (D2-вторая строка столбца D) написать следующее выражение:

  • =ЕСЛИ(И(A2="телевизор";B2="Россия";C2<15000);"+";)

Наименование

страна

Цена, руб

телевизор Россия 10000 +
холодильник Германия 10000 0
чайник Польша 2000 0
холодильник Россия 18000 0
телевизор Россия 160000 0
чайник Россия 1000 0
тостер Венгрия 1500 0
телевизор Китай 12000 0
холодильник Россия 19000 0
чайник Китай 1800 0
холодильник Белоруссия 10500 0
тостер Китай 2000 0
чайник Китай 2500 0
телевизор Россия 14800 +
холодильник Германия 25000 0

Зная, как работает функция условия "if", можно создавать вложенные циклы для решения более сложных задач и многократных проверок условий.

Подписывайтесь на наши группы в социальных сетях - смешные статьи, картинки и факты!